Commit 479829c4 authored by Ian Lynagh's avatar Ian Lynagh

Fix the ghci wrapper

The ${1+"$@"} was being evaluated by make, rather than being escaped.
parent 89597d21
......@@ -20,7 +20,7 @@ install_driver_ghci:
"$(MKDIRHIER)" $(DESTDIR)$(bindir)
"$(RM)" $(RM_OPTS) $(WRAPPER)
echo '#!$(SHELL)' >> $(WRAPPER)
echo 'exec $(bindir)/ghc-$(ProjectVersion) --interactive ${1+"$@"}' >> $(WRAPPER)
echo 'exec $(bindir)/ghc-$(ProjectVersion) --interactive $${1+"$$@"}' >> $(WRAPPER)
$(EXECUTABLE_FILE) $(WRAPPER)
"$(RM)" $(RM_OPTS) $(DESTDIR)$(bindir)/ghci
$(LN_S) ghci-$(ProjectVersion) $(DESTDIR)$(bindir)/ghci
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment