Commit de8443c1 authored by Herbert Valerio Riedel's avatar Herbert Valerio Riedel 🕺

Update process submodule

This is needed to prepare for #11026 as this update
relaxes the upper bounds on `base` to allow for `base-4.9.0.0`

This also needs to relax a few upper bounds on process in some cabal files

(there will be another process submodule update soon, as a major
version bump of process' version is still pending)
parent 12abc773
......@@ -46,7 +46,7 @@ Library
Build-Depends: base >= 4 && < 5,
directory >= 1 && < 1.3,
process >= 1 && < 1.3,
process >= 1 && < 1.4,
bytestring >= 0.9 && < 0.11,
time < 1.6,
containers >= 0.5 && < 0.6,
......
......@@ -31,7 +31,7 @@ Executable ghc
array >= 0.1 && < 0.6,
bytestring >= 0.9 && < 0.11,
directory >= 1 && < 1.3,
process >= 1 && < 1.3,
process >= 1 && < 1.4,
filepath >= 1 && < 1.5,
ghc
if os(windows)
......
Subproject commit e0983fbbfa8a3d81c7b99e83a3169fc686caab62
Subproject commit 4853d8f78a6831f4567ff0c2880298c9c70a5203
......@@ -20,7 +20,7 @@ Executable ghc-pkg
Build-Depends: base >= 4 && < 5,
directory >= 1 && < 1.3,
process >= 1 && < 1.3,
process >= 1 && < 1.4,
containers,
filepath,
Cabal,
......
Subproject commit 293f41c78e956b78363ede463e7ff52eb6bc997d
Subproject commit ff34f784abc868b22003717c1265d59af1c43a9f
......@@ -18,5 +18,5 @@ Executable runghc
Build-Depends: base >= 3 && < 5,
directory >= 1 && < 1.3,
process >= 1 && < 1.3,
process >= 1 && < 1.4,
filepath
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment