Commit ef062308 authored by Simon Marlow's avatar Simon Marlow
Browse files

check for bfd_uncompress_section_contents instead of bfd_init, because

the former will fail if libbfd is a static library and has a libz
dependency that we don't know about (#3756)
parent 02c4f417
......@@ -782,7 +782,7 @@ fi
dnl ** check whether this machine has BFD and liberty installed (used for debugging)
dnl the order of these tests matters: bfd needs liberty
AC_CHECK_LIB(iberty, xmalloc)
AC_CHECK_LIB(bfd, bfd_init)
AC_CHECK_LIB(bfd, bfd_uncompress_section_contents)
dnl ################################################################
dnl Check for libraries
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment