1. 18 Nov, 2009 1 commit
  2. 11 Nov, 2009 1 commit
    • Simon Marlow's avatar
      Support for DragonFly BSD · a35d65c3
      Simon Marlow authored
      Patches from Goetz Isenmann <info@goetz-isenmann.de>, slightly updated
      for HEAD (the method for configuring platforms in configure.ac has
      changed).
      a35d65c3
  3. 04 Nov, 2009 1 commit
  4. 29 Oct, 2009 2 commits
  5. 27 Oct, 2009 1 commit
  6. 23 Oct, 2009 2 commits
  7. 08 Oct, 2009 2 commits
  8. 04 Oct, 2009 1 commit
  9. 26 Sep, 2009 1 commit
  10. 22 Sep, 2009 1 commit
  11. 13 Sep, 2009 1 commit
  12. 11 Sep, 2009 1 commit
  13. 08 Sep, 2009 2 commits
  14. 26 Aug, 2009 1 commit
  15. 20 Aug, 2009 1 commit
    • Simon Marlow's avatar
      Restore the GHC version check · efc0f420
      Simon Marlow authored
      I'm not sure what happened here, but the ordering of tests was messed
      up, with the result that the GHC version check was being omitted.
      efc0f420
  16. 17 Aug, 2009 1 commit
  17. 14 Aug, 2009 1 commit
  18. 08 Aug, 2009 1 commit
  19. 06 Aug, 2009 1 commit
  20. 16 Jul, 2009 1 commit
    • Ian Lynagh's avatar
      Don't put all of $CFLAGS into $SRC_CC_OPTS · 17c5559e
      Ian Lynagh authored
      Instead, we just put the flags we need in there (e.g. -m64 on OS X 64).
      This fixes a problem found by Simon M, where we were compiling
      everything with -g, leading to a bloated RTS.
      17c5559e
  21. 09 Jul, 2009 1 commit
  22. 07 Jul, 2009 1 commit
  23. 06 Jul, 2009 1 commit
  24. 27 Jun, 2009 1 commit
  25. 16 Jun, 2009 1 commit
  26. 29 May, 2009 1 commit
  27. 10 Jun, 2009 1 commit
  28. 03 Jun, 2009 1 commit
  29. 02 Jun, 2009 2 commits
  30. 25 May, 2009 1 commit
  31. 23 May, 2009 3 commits
  32. 22 May, 2009 1 commit
    • Ian Lynagh's avatar
      Change how we find the host/build/target platforms · 82fbc4be
      Ian Lynagh authored
      Rather than using the autoconf built-in stuff and mangling it, we
      now just ask the bootstrapping compiler what platform we are on.
      
      When doing a port of GHC, you need to specify the platform you are
      porting to.
      
      The minimum version of GHC required is now 6.8.
      82fbc4be
  33. 21 May, 2009 1 commit