• Peter Trommler's avatar
    Update autoconf test for gcc to require 4.7 and up · 59de2909
    Peter Trommler authored
    Fixing #14244 required the newer gcc atomic built-ins that are provided
    from 4.7 and up. This updates the test to check for minimum gcc version
    4.7.
    
    The version tests for 3.4 (!), 4.4, and 4.6 are no longer needed and can
    be removed. This makes the build system simpler.
    
    Test Plan: validate
    
    Reviewers: austin, bgamari, hvr, simonmar
    
    Reviewed By: bgamari
    
    Subscribers: rwbarton, thomie, erikd
    
    Differential Revision: https://phabricator.haskell.org/D4165
    59de2909
config.mk.in 30.1 KB