Only enable emscripten on Debian 11

Since it requires LLVM 15, which is unavailable on earlier releases.
2 jobs for wip/emscripten in 1 minute and 57 seconds (queued for 1 minute and 22 seconds)
latest