Infrastructure for testing Hackage packages against GHC pre-releases.

  • Ryan Scott's avatar
    Remove unix-2.8 patching for now · 9a09dfe4
    Ryan Scott authored
    I originally patched these libraries in anticipation of GHC HEAD
    bundling the yet-to-be-released `unix-2.8` instead of `unix-2.7`.
    However, since then HEAD has switched back to `unix-2.7` and doesn't
    show any signs of going back to `2.8` any time soon. Keeping these
    patches around, therefore, is a bit wasteful since it results in
    more `Cabal` store cache misses without any benefits, since these
    libraries build on HEAD just fine. Until the need to actually adjust
    to `unix-2.8` arises once more, I'm going to remove these patches
    for now.
    9a09dfe4
Name
Last commit
Last update
ci Loading commit data...
patches Loading commit data...
scripts Loading commit data...
.gitignore Loading commit data...
.gitlab-ci.yml Loading commit data...
.travis.yml Loading commit data...
README.md Loading commit data...
default.nix Loading commit data...
ghc-from-source.nix Loading commit data...
ghc-prerelease.nix Loading commit data...
http-api-data.nix Loading commit data...
run-ci Loading commit data...