Commit 3cd9fc77 authored by Mikhail Glushenkov's avatar Mikhail Glushenkov
Browse files

Update the GHC compatibility policy.

7.2.2 was released on Nov 11 2011, so we don't have to support it in
the 2.0 release.
parent 2a2382f4
......@@ -152,15 +152,16 @@ Conventions
support window, except Template Haskell, which would cause
bootstrapping problems in the GHC compilation process.
* Our GHC support window is three years: that is, the Cabal library
must be buildable out-of-the-box with the dependencies that shipped
with GHC for at least three years. The Travis CI checks this, so
most developers submit a PR to see if their code works on all
these versions of Haskell. cabal-install must also be buildable
on all these GHCs, although it does not have to be buildable
* Our GHC support window is five years for the Cabal library and three
years for cabal-install: that is, the Cabal library must be
buildable out-of-the-box with the dependencies that shipped with GHC
for at least five years. The Travis CI checks this, so most
developers submit a PR to see if their code works on all these
versions of GHC. cabal-install must also be buildable on all
supported GHCs, although it does not have to be buildable
out-of-the-box. Instead, the `cabal-install/bootstrap.sh` script
must be able to download and install all of the dependencies.
(This is also checked by CI!)
must be able to download and install all of the dependencies. (This
is also checked by CI!)
* `Cabal` has its own Prelude, in `Distribution.Compat.Prelude`,
that provides a compatibility layer and exports some commonly
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment