Commit 8977b657 authored by Ryan Scott's avatar Ryan Scott
Browse files

Require echo-0.1.3

echo-0.1.3 introduces a dependency on the minimalistic mintty library, so we
need to add that to ./bootstrap.sh as well.
parent 8866ca35
......@@ -261,8 +261,10 @@ BASE64_BYTESTRING_VER="1.0.0.1"; BASE64_BYTESTRING_VER_REGEXP="1\."
# >=1.0
CRYPTOHASH_SHA256_VER="0.11.100.1"; CRYPTOHASH_SHA256_VER_REGEXP="0\.11\.?"
# 0.11.*
ECHO_VER="0.1"; ECHO_VER_REGEXP="0\.1\.?"
MINTTY_VER="0.1"; MINTTY_VER_REGEXP="0\.1\.?"
# 0.1.*
ECHO_VER="0.1.3"; ECHO_VER_REGEXP="0\.1\.[3-9]"
# >= 0.1.3 && < 0.2
EDIT_DISTANCE_VER="0.2.2.1"; EDIT_DISTANCE_VER_REGEXP="0\.2\.2\.?"
# 0.2.2.*
ED25519_VER="0.0.5.0"; ED25519_VER_REGEXP="0\.0\.?"
......@@ -489,6 +491,7 @@ info_pkg "base64-bytestring" ${BASE64_BYTESTRING_VER} \
${BASE64_BYTESTRING_VER_REGEXP}
info_pkg "cryptohash-sha256" ${CRYPTOHASH_SHA256_VER} \
${CRYPTOHASH_SHA256_VER_REGEXP}
info_pkg "mintty" ${MINTTY_VER} ${MINTTY_VER_REGEXP}
info_pkg "echo" ${ECHO_VER} ${ECHO_VER_REGEXP}
info_pkg "edit-distance" ${EDIT_DISTANCE_VER} ${EDIT_DISTANCE_VER_REGEXP}
info_pkg "ed25519" ${ED25519_VER} ${ED25519_VER_REGEXP}
......@@ -526,6 +529,7 @@ do_pkg "base64-bytestring" ${BASE64_BYTESTRING_VER} \
${BASE64_BYTESTRING_VER_REGEXP}
do_pkg "cryptohash-sha256" ${CRYPTOHASH_SHA256_VER} \
${CRYPTOHASH_SHA256_VER_REGEXP}
do_pkg "mintty" ${MINTTY_VER} ${MINTTY_VER_REGEXP}
do_pkg "echo" ${ECHO_VER} ${ECHO_VER_REGEXP}
do_pkg "edit-distance" ${EDIT_DISTANCE_VER} ${EDIT_DISTANCE_VER_REGEXP}
do_pkg "ed25519" ${ED25519_VER} ${ED25519_VER_REGEXP}
......
......@@ -356,7 +356,7 @@ executable cabal
containers >= 0.4 && < 0.6,
cryptohash-sha256 >= 0.11 && < 0.12,
deepseq >= 1.3 && < 1.5,
echo >= 0.1 && < 0.2,
echo >= 0.1.3 && < 0.2,
edit-distance >= 0.2.2 && < 0.3,
filepath >= 1.3 && < 1.5,
hashable >= 1.0 && < 2,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment