Commit 91dc14ca authored by Oleg Grenrus's avatar Oleg Grenrus

Bump version to 3.1.0.0

parent dc138034
cabal-version: >=1.10
name: Cabal
version: 3.0.0.0
version: 3.1.0.0
copyright: 2003-2019, Cabal Development Team (see AUTHORS file)
license: BSD3
license-file: LICENSE
......
# 3.0.0.0 (current development version)
# 3.1.0.0 (current development version)
# 3.0.0.0 TBD
* TODO
* Introduce set notation for `^>=` and `==` operators
([#5906](https://github.com/haskell/cabal/pull/5906)).
......
VERSION=3.0.0.0
VERSION=3.1.0.0
#KIND=devel
KIND=rc
......
......@@ -13,7 +13,7 @@ import sphinx_rtd_theme
sys.path.insert(0, os.path.abspath('.'))
import cabaldomain
version = "3.0.0.0"
version = "3.1.0.0"
extensions = ['sphinx.ext.extlinks', 'sphinx.ext.todo']
......
......@@ -3,6 +3,7 @@
branches:
only:
- master
- "3.0"
- "2.4"
- "2.2"
- "2.0"
......@@ -47,7 +48,7 @@ build_script:
- cabal %CABOPTS% new-test Cabal
- appveyor-retry cabal %CABOPTS% new-build exe:cabal exe:cabal-tests --only-dependencies
- cabal %CABOPTS% new-build exe:cabal
- cabal %CABOPTS% new-run cabal-tests -- -j3 --with-cabal=dist-newstyle\build\x86_64-windows\ghc-8.0.2\cabal-install-3.0.0.0\x\cabal\build\cabal\cabal.exe
- cabal %CABOPTS% new-run cabal-tests -- -j3 --with-cabal=dist-newstyle\build\x86_64-windows\ghc-8.0.2\cabal-install-3.1.0.0\x\cabal\build\cabal\cabal.exe
- appveyor-retry cabal %CABOPTS% new-build cabal-install:tests --only-dependencies
- cd cabal-install
- cabal %CABOPTS% new-run cabal-install:memory-usage-tests
......
......@@ -224,7 +224,7 @@ NETWORK_URI_VER="2.6.1.0"; NETWORK_URI_VER_REGEXP="2\.6\.(0\.[2-9]|[1-9])"
# >= 2.6.0.2 && < 2.7
NETWORK_VER="2.7.0.0"; NETWORK_VER_REGEXP="2\.[0-7]\."
# >= 2.0 && < 2.7
CABAL_VER="3.0.0.0"; CABAL_VER_REGEXP="3\.0\.[0-9]"
CABAL_VER="3.1.0.0"; CABAL_VER_REGEXP="3\.1\.[0-9]"
# >= 2.5 && < 2.6
TRANS_VER="0.5.5.0"; TRANS_VER_REGEXP="0\.[45]\."
# >= 0.2.* && < 0.6
......
......@@ -4,7 +4,7 @@ Cabal-Version: >= 1.10
-- To update this file, edit 'cabal-install.cabal.pp' and run
-- 'make cabal-install-prod' in the project's root folder.
Name: cabal-install
Version: 3.0.0.0
Version: 3.1.0.0
Synopsis: The command-line interface for Cabal and Hackage.
Description:
The \'cabal\' command-line program simplifies the process of managing
......@@ -312,7 +312,7 @@ executable cabal
base16-bytestring >= 0.1.1 && < 0.2,
binary >= 0.7.3 && < 0.9,
bytestring >= 0.10.6.0 && < 0.11,
Cabal == 3.0.*,
Cabal == 3.1.*,
containers >= 0.5.6.2 && < 0.7,
cryptohash-sha256 >= 0.11 && < 0.12,
deepseq >= 1.4.1.1 && < 1.5,
......
......@@ -10,7 +10,7 @@ Cabal-Version: >= 1.10
-- To update this file, edit 'cabal-install.cabal.pp' and run
-- 'make cabal-install-prod' in the project's root folder.
Name: cabal-install
Version: 3.0.0.0
Version: 3.1.0.0
#
# NOTE: when updating build-depends, don't forget to update version regexps in bootstrap.sh.
#
......@@ -22,7 +22,7 @@ Version: 3.0.0.0
base16-bytestring >= 0.1.1 && < 0.2,
binary >= 0.7.3 && < 0.9,
bytestring >= 0.10.6.0 && < 0.11,
Cabal == 3.0.*,
Cabal == 3.1.*,
containers >= 0.5.6.2 && < 0.7,
cryptohash-sha256 >= 0.11 && < 0.12,
deepseq >= 1.4.1.1 && < 1.5,
......@@ -475,7 +475,7 @@ executable cabal
cpp-options: -DMONOLITHIC
build-depends:
Cabal == 3.0.*,
Cabal == 3.1.*,
cabal-install-solver-dsl,
QuickCheck >= 2.8.2,
array,
......
-*-change-log-*-
3.0.0.0 (current development version)
3.1.0.0 (current development version)
3.0.0.0 TBD
* `v2-repl` no longer changes directory to a randomized temporary folder
when used outside of a project. (#5544)
* `install-method` and `overwrite-policy` in `.cabal/config` now actually work. (#5942)
......
cabal-version: 2.2
name: cabal-testsuite
version: 3.0.0.0
version: 3.1.0.0
copyright: 2003-2019, Cabal Development Team (see AUTHORS file)
license: BSD-3-Clause
license-file: LICENSE
......@@ -28,7 +28,7 @@ common shared
build-depends:
, base >= 4.6 && <4.13
-- this needs to match the in-tree lib:Cabal version
, Cabal == 3.0.0.0
, Cabal == 3.1.0.0
ghc-options: -Wall -fwarn-tabs
......@@ -102,5 +102,5 @@ executable setup
custom-setup
-- we only depend on even stable releases of lib:Cabal
setup-depends: Cabal == 2.2.* || == 2.4.* || == 3.0.*,
setup-depends: Cabal == 2.2.* || == 2.4.* || == 3.0.* || ==3.1.*,
base, filepath, directory
name: solver-benchmarks
version: 3.0.0.0
version: 3.1.0.0
copyright: 2003-2017, Cabal Development Team (see AUTHORS file)
license: BSD3
license-file: LICENSE
......
set -e
HACKAGE_REPO_TOOL_VERSION="0.1.1.1"
CABAL_VERSION="3.0.0.0"
CABAL_INSTALL_VERSION="3.0.0.0"
CABAL_VERSION="3.1.0.0"
CABAL_INSTALL_VERSION="3.1.0.0"
if [ "$TRAVIS_OS_NAME" = "linux" ]; then
ARCH="x86_64-linux"
......
......@@ -8,7 +8,7 @@ deploy() {
(cd cabal-website && git checkout --track -b gh-pages origin/gh-pages)
rm -rf cabal-website/doc
mkdir -p cabal-website/doc/html
mv dist-newstyle/build/`uname -m`-$TRAVIS_OS_NAME/ghc-$GHCVER/Cabal-3.0.0.0/doc/html/Cabal \
mv dist-newstyle/build/`uname -m`-$TRAVIS_OS_NAME/ghc-$GHCVER/Cabal-3.1.0.0/doc/html/Cabal \
cabal-website/doc/html/Cabal
(cd cabal-website && git add --all .)
(cd cabal-website && \
......
......@@ -177,7 +177,7 @@ timed $CABALPLAN --version
#######################################################################
# NOTE: This should match cabal-testsuite version
CABAL_VERSION="3.0.0.0"
CABAL_VERSION="3.1.0.0"
if [ "$(uname)" = "Linux" ]; then
ARCH="x86_64-linux"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment