Commit c1ddaaca authored by Oleg Grenrus's avatar Oleg Grenrus

Bump more upper bounds

parent 37a0d312
......@@ -613,14 +613,14 @@ test-suite unit-tests
directory,
filepath,
integer-logarithms >= 1.0.2 && <1.1,
tasty >= 1.1.0.3 && < 1.2,
tasty >= 1.2.3 && < 1.3,
tasty-hunit,
tasty-quickcheck,
tagged,
temporary,
text,
pretty,
QuickCheck >= 2.11.3 && < 2.12,
QuickCheck >= 2.13.2 && < 2.14,
Cabal
ghc-options: -Wall
default-language: Haskell2010
......@@ -631,11 +631,11 @@ test-suite parser-tests
main-is: ParserTests.hs
build-depends:
base,
base-compat >=0.10.4 && <0.11,
base-compat >=0.11.0 && <0.12,
bytestring,
directory,
filepath,
tasty >= 1.1.0.3 && < 1.2,
tasty >= 1.2.3 && < 1.3,
tasty-hunit,
tasty-quickcheck,
tasty-golden >=2.3.1.1 && <2.4,
......@@ -649,7 +649,7 @@ test-suite parser-tests
if impl(ghc >= 7.8)
build-depends:
tree-diff >= 0.0.2 && <0.1
tree-diff >= 0.1 && <0.2
other-modules:
Instances.TreeDiff
Instances.TreeDiff.Language
......@@ -665,7 +665,7 @@ test-suite check-tests
bytestring,
directory,
filepath,
tasty >= 1.1.0.3 && < 1.2,
tasty >= 1.2.3 && < 1.3,
tasty-golden >=2.3.1.1 && <2.4,
Diff >=0.4 && <0.5,
Cabal
......@@ -709,15 +709,15 @@ test-suite hackage-tests
filepath
build-depends:
base-compat >=0.10.4 && <0.11,
base-compat >=0.11.0 && <0.12,
base-orphans >=0.6 && <0.9,
optparse-applicative >=0.13.2.0 && <0.15,
optparse-applicative >=0.13.2.0 && <0.16,
stm >=2.4.5.0 && <2.6,
tar >=0.5.0.3 && <0.6
if impl(ghc >= 7.8)
build-depends:
tree-diff >= 0.0.2 && <0.1
tree-diff >= 0.1 && <0.2
other-modules:
Instances.TreeDiff
Instances.TreeDiff.Language
......@@ -739,7 +739,7 @@ test-suite rpmvercmp
bytestring
build-depends:
tasty >= 1.1.0.3 && < 1.2,
tasty >= 1.2.3 && < 1.3,
tasty-hunit,
tasty-quickcheck,
QuickCheck
......
......@@ -308,7 +308,7 @@ executable cabal
build-depends:
async >= 2.0 && < 2.3,
array >= 0.4 && < 0.6,
base >= 4.8 && < 4.13,
base >= 4.8 && < 4.14,
base16-bytestring >= 0.1.1 && < 0.2,
binary >= 0.7.3 && < 0.9,
bytestring >= 0.10.6.0 && < 0.11,
......
......@@ -18,7 +18,7 @@ Version: 3.1.0.0
build-depends:
async >= 2.0 && < 2.3,
array >= 0.4 && < 0.6,
base >= 4.8 && < 4.13,
base >= 4.8 && < 4.14,
base16-bytestring >= 0.1.1 && < 0.2,
binary >= 0.7.3 && < 0.9,
bytestring >= 0.10.6.0 && < 0.11,
......@@ -495,7 +495,7 @@ executable cabal
random,
tagged,
tar,
tasty >= 1.1.0.3 && < 1.2,
tasty >= 1.2.3 && < 1.3,
tasty-hunit >= 0.10,
tasty-quickcheck,
tree-diff,
......@@ -561,7 +561,7 @@ Test-Suite unit-tests
zlib,
network-uri < 2.6.2.0,
network,
tasty >= 1.1.0.3 && < 1.2,
tasty >= 1.2.3 && <1.3,
tasty-hunit >= 0.10,
tasty-quickcheck,
tagged,
......@@ -593,7 +593,7 @@ Test-Suite memory-usage-tests
containers,
deepseq,
tagged,
tasty >= 1.1.0.3 && < 1.2,
tasty >= 1.2.3 && <1.3,
tasty-hunit >= 0.10
ghc-options: -threaded
......@@ -622,7 +622,7 @@ Test-Suite solver-quickcheck
hashable,
random,
tagged,
tasty >= 1.1.0.3 && <1.2,
tasty >= 1.2.3 && <1.3,
tasty-quickcheck,
QuickCheck >= 2.8.2,
pretty-show >= 1.6.15
......@@ -650,7 +650,7 @@ test-suite integration-tests2
directory,
edit-distance,
filepath,
tasty >= 1.1.0.3 && < 1.2,
tasty >= 1.2.3 && <1.3,
tasty-hunit >= 0.10,
tagged
......
......@@ -61,7 +61,7 @@ library
, directory ^>= 1.2.0.1 || ^>= 1.3.0.0
, exceptions ^>= 0.10.0
, filepath ^>= 1.3.0.1 || ^>= 1.4.0.0
, optparse-applicative ^>= 0.14.3.0
, optparse-applicative ^>= 0.14.3.0 || ^>=0.15.1.0
, process ^>= 1.1.0.2 || ^>= 1.2.0.0 || ^>= 1.4.2.0 || ^>= 1.6.1.0
, regex-compat-tdfa ^>= 0.95.1.4
, regex-tdfa ^>= 1.2.3.1
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment