• Ömer Sinan Ağacan's avatar
    LLVM backend: Show expected LLVM version in warnings/errors · 0e9a331f
    Ömer Sinan Ağacan authored
    Summary:
    Before:
    
        [1 of 1] Compiling Main             ( Main.hs, Main.o )
        You are using a new version of LLVM that hasn't been tested yet!
        We will try though...
    
    After:
    
        [1 of 1] Compiling Main             ( Main.hs, Main.o )
        You are using an unsupported version of LLVM!
        Currently only 3.7 is supported.
        We will try though...
    
    Before:
    
        [1 of 1] Compiling Main             ( Main.hs, Main.o )
    
        <no location info>:
            Warning: Couldn't figure out LLVM version!
                     Make sure you have installed LLVM
        ghc: could not execute: opt
    
    After:
    
        [1 of 1] Compiling Main             ( Main.hs, Main.o )
    
        <no location info>: error:
            Warning: Couldn't figure out LLVM version!
                     Make sure you have installed LLVM 3.7
        ghc-stage1: could not execute: opt
    
    Reviewers: austin, rwbarton, bgamari
    
    Subscribers: thomie
    
    Differential Revision: https://phabricator.haskell.org/D1658
    0e9a331f
LlvmCodeGen.hs 5.91 KB